Thread
metalsnake Avatar
new RTX 2080 Ti Windforce, oc scan option constantly fails
Bookmark Falling Locked
7 replies
1,084 views
  last post by
Feb 5, 2019 19:14:16 GMT -8
Guest Avatar
Thread
Guest Avatar
new RTX 2080 Ti fans behave weird
Bookmark Falling Locked
30 replies
4,773 views
  last post by
Feb 5, 2019 7:54:08 GMT -8
mogitu Avatar
Thread
Guest Avatar
new Gigabyte Windforce RTX 2070 artifacting and crashing games
Bookmark Falling Locked
12 replies
2,128 views
  last post by
Feb 2, 2019 7:34:26 GMT -8
Guest Avatar
Thread
Guest Avatar
new RTX 2070 8g gaming OC stuttering
Bookmark Falling Locked
1 reply
317 views
  last post by
Feb 1, 2019 22:09:05 GMT -8
Guest Avatar
Thread
mogitu Avatar
new Fan spinning up and down rtx 2080 TI gaming oc.
Bookmark Falling Locked
4 replies
268 views
  last post by
Jan 29, 2019 9:48:08 GMT -8
mogitu Avatar
Thread
GIGABYTE - Matt Avatar
new NEW 2080/Ti Gaming OC BIOS - Higher Power Limit
Bookmark Falling Locked
240 replies
30,241 views
  last post by
Jan 29, 2019 6:17:31 GMT -8
Guest Avatar
Thread
jmuz689 Avatar
new RTX 2080 Ti XTREME WATERFORCE 11G BIOS and powerlimit
Bookmark Falling Locked
0 replies
130 views
  last post by
Jan 28, 2019 1:29:28 GMT -8
jmuz689 Avatar
Thread
cptplats Avatar
new 2080 ti gaming oc
Bookmark Falling Locked
1 reply
184 views
  last post by
Jan 27, 2019 14:59:52 GMT -8
mogitu Avatar
Thread
mogitu Avatar
new RTX 2080 TI gaming oc temps.
Bookmark Falling Locked
4 replies
168 views
  last post by
Jan 27, 2019 14:24:30 GMT -8
mogitu Avatar
Thread
rambler Avatar
new RTX 2080 Windforce OC F4_beta in .ROM
Bookmark Falling Locked
0 replies
138 views
  last post by
Jan 26, 2019 18:42:16 GMT -8
rambler Avatar
Thread
Guest Avatar
new GeForce RTX 2080 Ti XTREME WATERFORCE GV-N208TAORUSX W-11GC
Bookmark Falling Locked
3 replies
592 views
  last post by
Jan 26, 2019 17:33:48 GMT -8
nandanph Avatar
Thread
mehoo222 Avatar
new GeForce GTX 1060 6GB NO VIDEO
Bookmark Falling Locked
4 replies
169 views
  last post by
Jan 25, 2019 16:51:06 GMT -8
Calab Avatar
Thread
Calab Avatar
new No picutre with any DisplayPort port on GTX 1080 Windforce
Bookmark Falling Locked
0 replies
87 views
  last post by
Jan 25, 2019 16:33:24 GMT -8
Calab Avatar
Thread
xthebaker Avatar
new RTX 2080 Ti Gaming OC Fans Do Not Stop
Bookmark Falling Locked
1 reply
195 views
  last post by
Jan 25, 2019 15:17:59 GMT -8
bandit8623 Avatar
Thread
fixalltheproblems Avatar
new Fix all the problems with 20xx cards
Bookmark Falling Locked
14 replies
888 views
  last post by
Jan 25, 2019 15:14:19 GMT -8
bandit8623 Avatar
Thread
bryjas Avatar
new Aorus RTX 2080 Ti Xtreme FAN&LED problem weird sounds ......
Bookmark Falling Locked
2 replies
393 views
  last post by
Jan 25, 2019 14:52:50 GMT -8
bryjas Avatar
Thread
soap Avatar
new RTX 2070 causing my computer not to boot
Bookmark Falling Locked
3 replies
150 views
  last post by
Jan 25, 2019 11:19:21 GMT -8
val Avatar
Thread
style86 Avatar
new RTX 2080 Gaming OC 8G fans on all time
Bookmark Falling Locked
4 replies
377 views
  last post by
Jan 24, 2019 5:46:06 GMT -8
xthebaker Avatar
Thread
sew333 Avatar
new 2080 Ti Aorus - not passed Ultra Fire Strike Stress Test .
Bookmark Falling Locked
1 reply
190 views
  last post by
Jan 22, 2019 8:57:23 GMT -8
val Avatar
Thread
killerbee04x Avatar
new intel says 2080 8g is only 4g
Bookmark Falling Locked
1 reply
155 views
  last post by
Jan 22, 2019 8:09:06 GMT -8
val Avatar
Thread
Guest Avatar
new Gigabyte Aorus 2080 Xtreme Waterforce
Bookmark Falling Locked
1 reply
226 views
  last post by
Jan 20, 2019 11:17:47 GMT -8
cube Avatar
Thread
Guest Avatar
new Aorus RTX 2080 Ti Xtreme FAN&LED problem weird sounds ......
Bookmark Falling Locked
0 replies
84 views
  last post by
Jan 19, 2019 7:51:04 GMT -8
Guest Avatar
Thread
Guest Avatar
new It's been 2 months on the faulty fans problem (RTX Cards)
Bookmark Falling Locked
41 replies
2,471 views
  last post by
Jan 19, 2019 7:37:59 GMT -8
Guest Avatar
Thread
Guest Avatar
new Please approve my 2080 TI temperature
Bookmark Falling Locked
0 replies
136 views
  last post by
Jan 18, 2019 2:37:24 GMT -8
Guest Avatar
Thread
Guest Avatar
new Aorus 2080 TI Xtreme Fan Issues (One fan keeps pulsing)
Bookmark Falling Locked
0 replies
119 views
  last post by
Jan 16, 2019 18:51:10 GMT -8
Guest Avatar
Thread
Guest Avatar
new Unable To Register 4 Year Warranty
Bookmark Falling Locked
2 replies
192 views
  last post by
Jan 16, 2019 11:17:55 GMT -8
Guest Avatar
Thread
Guest Avatar
new rtx 2080 ti xtreme (extra connector)
Bookmark Falling Locked
0 replies
128 views
  last post by
Jan 15, 2019 8:32:19 GMT -8
Guest Avatar
Thread
coinup Avatar
new Windforce OC rtx 2080ti max temps
Bookmark Falling Locked
11 replies
316 views
  last post by
Jan 14, 2019 20:29:06 GMT -8
val Avatar
Thread
pixxor Avatar
new 2080ti Xtreme waterforce 11G Powerlimit
Bookmark Falling Locked
3 replies
283 views
  last post by
Jan 12, 2019 5:00:17 GMT -8
mortemas Avatar
Thread
vrbaa Avatar
new GTX 970 G1 Gaming - thermal pads thickness?
Bookmark Falling Locked
1 reply
242 views
  last post by
Jan 11, 2019 12:15:19 GMT -8
einmachglas Avatar

Legend

Thread Announcement Sticky Locked new New Poll Bookmark
chong83 Avatar
chong83 wrote: Feb 16, 2019 7:32:57 GMT -8
check the task manager which software progress use high CPU or SSD
totallypissedoff Avatar
totallypissedoff wrote: Feb 16, 2019 5:02:17 GMT -8
Try downloading, and installing the Aorus Graphics Engine directly from the Gigabyte website. Installing from the disk is not the best idea, as it is most likely an older version of the software.
dvojinov Avatar
dvojinov wrote: Feb 14, 2019 2:59:58 GMT -8
hello , does someone knows where to download older version of Aours VGA tool 1.52?
vanowm Avatar
vanowm wrote: Feb 13, 2019 16:12:37 GMT -8
, you need connect your monitor to motherboard, enter bios and set PCI-E graphic card as primary.
bigdave Avatar
bigdave wrote: Feb 13, 2019 12:41:06 GMT -8
spaceweasel,Use the NVIDIA Control Panel -->Help-->system information.
spaceweasel Avatar
spaceweasel wrote: Feb 13, 2019 11:47:46 GMT -8
I have an Aorus RTX280 Extreme card. What's the easiest way to check firmware version?
mechanicman91 Avatar
mechanicman91 wrote: Feb 12, 2019 20:02:48 GMT -8
i just put together a B450I ryzen 2400G system with 16gb of G Skill ddr4 3200 and a 970 evo. the pc will turn on, but the monitor wont detect until it is past bios. just curious if any of y'all have seen this before.
dimentograven Avatar
dimentograven wrote: Feb 12, 2019 17:55:21 GMT -8
Is there any way to turn Easy Raid off once activated? I turned it on thinking I could setup two NVME drives in a stripe, but when I enabled Easy Raid, I found the NVME drives don't show up in the list, and th the existing SATA SSD no longer properly boot
karambit Avatar
karambit wrote: Feb 12, 2019 10:09:32 GMT -8
Are the mounting holes for an EK Monoblock for the newer Z390( Ultra, pro or Designare)in the same position and series as the Z37 Aorus Gaming 7 ?
yuki Avatar
yuki wrote: Feb 12, 2019 4:30:22 GMT -8
I'm having issues with removing the SSD Screw from the Heatsink, Using the Z390 Board. Any tips removing the screw? It feels like they are super tight
galving Avatar
galving wrote: Feb 12, 2019 3:14:12 GMT -8
I'm having similar issues. on the z390 xtreme with g.skill royal 4266mhz. system doesn't boot with xmp enabled
Dragzilla66 Avatar
Dragzilla66 wrote: Feb 11, 2019 15:12:56 GMT -8
Hello fellow Gigabyte users.
warpigs Avatar
warpigs wrote: Feb 9, 2019 20:56:42 GMT -8
Hello All, New build getting A6 error code..Gigabyte Z390 Aorus Ultra v 1.0..I tried with my 2 M.2 SSD's out and still get as well. Any advise? Thank you in advance.
hannanfix Avatar
hannanfix wrote: Feb 9, 2019 11:19:51 GMT -8
My Motherboard is Z370 AORUS Gaming 5. Processor 9700k. Samsung 970 M.2 NVME and ADATA XPG M.2 NVME. Graphics XFX RX 580.

I installed GC-ALPINE RIDGE (rev. 1.0) but in Bios it did not show. I update and downgrade BIOS no hope. Then I Disconnected MY All
*
hannanfix Avatar
hannanfix wrote: Feb 9, 2019 11:09:21 GMT -8
Gigabyte Z370 AORUS Gaming 5 My Board. After upgrading BIOS F12c My Hackintosh is unable to load. I am a very serious Ex pert in Hackintosh. Then I downgrade and F10 and everything OK.
grichie Avatar
grichie wrote: Feb 9, 2019 7:00:57 GMT -8
I just purchased and installed a new gigabyte Geforce 1050 and installed the software from the included disk. I have not been able to find or access the aorus engine to make adjustments to the graphics card.


Can anyone tell me how to find this feature?
*
vanowm Avatar
vanowm wrote: Feb 9, 2019 6:32:09 GMT -8
, contact tech support. If the ram in QVL list they will need fix their f-up in bios.
mmanfroni Avatar
mmanfroni wrote: Feb 8, 2019 20:07:19 GMT -8
hi guys, someone use 4266mhz rams? i have aorus master z390 and at max frequence system is instable/dont boot, at 4000 is stable.
vanowm Avatar
vanowm wrote: Feb 8, 2019 15:25:27 GMT -8
, try another power supply, then remove/unplug everything except power supply, then add cpu, next ram. Test it after each step, If not changes between all these steps, then I'd say it's dead.
joaomonteiro Avatar
joaomonteiro wrote: Feb 8, 2019 4:24:02 GMT -8
Hello everyone. I need some help about my Gigabyte GA-X58a-UD7. i died on me and i can only see the poder and the clear cmos light on. before this i only saw all led's lid up and error code 88 for brief second. is it really dead or is it salvagable?